QuantLib problems with gcc/g++ 3.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

QuantLib problems with gcc/g++ 3.0

Dirk Eddelbuettel
Debian attempts to support just as many platforms as we can. QuantLib is
already available most of them [1].  However, the hppa platform poses a
slight problem as their only compiler is GCC 3.0. This new version of GCC,
and G++, is known to be triggering quite a few errors in C++ code. QuantLib
is no exception.

I was wondering if somebody else had already attempted to address these g++
3.0 issues [2]. If so, I'd love to hear about it, especially if you have
patches :)  


(Debian maintainer for QuantLib, and some other packages)

[1] The count is currently at eleven: alpha, arm, hurd-i386, i386, ia64,
m68k, mips, mipsel, powerpc, s390, sparc

[2] For those of you running Debian testing or unstable, "apt-get install
g++-3.0" will pull in the compiler (plus libraries etc).

Our mailserver had a hardware failure while we were gone during the 2nd half
of July. I did not respond to a mail you sent then, or if you experienced a
a mail bounce, could you kindly resend it? Sorry for the inconvenience --Dirk